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Keyboard shortcuts
The following table summarizes the function keys in BitEdit.
Press this To
Alt+Bksp Undo the last change
Alt+F4 Quit BitEdit
Ctrl+A Select the entire bitmap
Ctrl+Ins Copy a selection to the Clipboard
Del Delete a selection
F5 Reorder palette with selected colors first
F6 Select in PalEdit
F7 Display a bitmap's palette
F8 Display Color Reduction dialog box
F12 Save changes as a specified file
Shift+Del Cut a selection to the Clipboard
Shift+F12 Save a file
Shift+Ins Paste from the Clipboard



Menu commands
To display help about a command, choose the menu containing the command you want.

File menu
New
Open
Close
Save
Save As
Revert
Run BitEdit
Exit

Edit menu
Undo
Cut
Copy
Paste
Paste Without Color
Paste Palette
Delete
Select All
Preferences

Selection menu
Crop
Flip Horizontal
Flip Vertical
Rotate
Selected Colors First
Select In PalEdit

Option menu
Show Palette
Color Reduction
Resize Image
Use Transparency



Step-by-step procedures
Click a procedure to jump to step-by-step instructions about that topic. Use the scroll bar to see more topics.

Working with bitmap files
Creating a new bitmap file
Opening a bitmap file
Quitting BitEdit
Saving changes to a bitmap
Setting preferences
Selecting parts of the bitmap
Detaching and moving the selected area
Moving a copy of the selected area
Moving the selection box
Resizing the selection box
Selecting an area of a bitmap
Editing the bitmap
Cropping a bitmap
Flipping the selected area
Pasting into a new BitEdit window
Pasting into the selected area
Pasting without an area selected
Pasting without Clipboard colors
Resizing a bitmap
Rotating the selection
Undoing changes
Using transparent color
Drawing on a bitmap
Changing background and foreground colors
Changing the shape of the brush
Controlling line width
Drawing ellipses and circles
Drawing rectangles
Drawing straight lines
Filling in a section of a bitmap
Using the brush tool
Using the color eraser tool
Using the zoom control tool
Working with palettes
Reducing colors
Reordering a color palette
Replacing a bitmap palette
Selecting palette colors from BitEdit



BitEdit tools
A tool palette appears along the left edge of the BitEdit window or where you last placed it. To use a tool, click the 
tool you want with the left mouse button.
Click a topic to jump to help about that tool

 Selection tool

 Flood fill tool

 Brush tool

 Color eraser tool

 Rectangle tool

 Current color tool

 Rounded rectangle tool

 Line size tool

 Ellipse tool

 Brush shape tool

 Line tool

 Zoom control tool

 Color dropper tool



BitEdit
A utility for working with bitmap files. BitEdit lets you perform simple edits and color changes to bitmap files.



Setting preferences
Step-by-step

You can customize BitEdit's working environment.

To set preferences:
1. From the Edit menu, choose Preferences.
2. Choose the preferences you want:

Choose Resize Window to Bitmap On Open to automatically adjust the BitEdit window to the size of the 
opened bitmap.

Choose Disable Undo to disable the Undo command, which frees memory for other uses, such as 
editing very large bitmaps.

Choose Detached Tools Window to display the BitEdit tools in a detached window that you can 
move to a convenient location onscreen.
3. Click OK.



Opening a bitmap file
Step-by-step

You can open an existing bitmap file in any of several file formats.

To open a bitmap file:
1. From the File menu, choose Open.
2. Under List Files Of Type, select the file format you want.
3. Under File Name, type the name of the file you want to open. Or double-click a file name in the box.

If the file you want is in a directory other than the current one, under Directories, select a new path.
4. Click OK.

See also
Valid file formats to open
Valid file formats to save



Creating a new bitmap file
Step-by-step

To create a new bitmap file:
1. From the File, choose New.
2. In the Width box, enter a width in pixels for the bitmap you want to create.
3. In the Height box, enter a height in pixels.
4. Choose the number of bits per pixel you want the new bitmap to have.
5. Choose OK.

See also
Drawing ellipses and circles
Drawing rectangles
Drawing straight lines



Saving changes to a bitmap
Step-by-step

BitEdit can save your changes to a bitmap in any of several file formats.

To save a bitmap with a new name or in a different format:
1. From the File menu, choose Save As.
2. Under File Name, type a name of up to eight characters for the bitmap file.
3. Under List Files Of Type, select the file format you want.
4. Under Directories, select a new path to save the file in a directory other than the current one.
5. Click OK.

See also
Valid file formats to open
Valid file formats to save



Quitting BitEdit
Step-by-step

If you quit BitEdit before saving changes you made to the current bitmap, BitEdit prompts you to save or discard 
the changes. Choose Yes to save changes and quit, No to quit without saving changes, or Cancel to continue 
using BitEdit.
You can also quit BitEdit by closing the BitEdit window.

To quit BitEdit:

From the File menu, choose Exit.
To quit BitEdit by closing the BitEdit window:

Double-click the Control-menu box. Or press Alt+F4.



Selecting an area of a bitmap
Step-by-step

You use the selection tool to select areas of the bitmap or the entire bitmap so that you can work with it. The 
selection tool creates a selection box around the area you want to select.

To select an area of an image:
1. Click the selection tool, then point to one corner of the bitmap area you want to select.
2. Hold down the left mouse button and drag to the opposite corner of the area you want, then release the mouse 

button.
To cancel the selection, click outside the selected area or select a different tool.

See also
Moving the selection box
Resizing the selection box



Moving the selection box
Step-by-step

You can move a selection box to select a different bitmap area.

To move a selection box:

Point inside the flashing red border of the selection box, then drag to a new position and release 
the mouse button.

If the selection box turns blue, release the mouse button, click outside the selected area, and try 
again. Make sure the tip of the pointer touches the border of the selection box.
See also
Resizing the selection box
Selecting an area in the bitmap



Resizing the selection box
Step-by-step

You can resize a selection box to enclose more or less of a selected bitmap area.

To resize a selection box:

Point to a handle at the corner of the selection box, then drag the handle in the direction you want.
See also
Moving the selection box
Selecting an area in the bitmap



Detaching and moving the selected area
Step-by-step

You can detach a selected bitmap area and move it to another location in the same bitmap. As you move the 
selected bitmap area, the old bitmap area is filled with the background color.

To detach and move a selected area:
1. Select the bitmap area you want to detach.
2. Drag the selection box with the left mouse button to the new position.
3. Release the mouse button.

To adjust the position, you can drag the selection box again.
4. To set the position of the detached selection, click outside the selection box.

See also
Moving the selection box
Selecting an area in the bitmap



Moving a copy of the selected area
Step-by-step

You can detach a copy of a selected bitmap area and move it to another location in the same bitmap. As you move
the selected bitmap area, the old bitmap area is filled with the background color.

To copy and move a selected area:
1. Select the bitmap area you want to copy and move.
2. Drag the selection box with the right mouse button to the new position.
3. Release the mouse button.

To adjust the position, you can drag the selection box again.
4. To set the position of the copied selection, click the left mouse button outside the selection box.

See also
Moving the selection box
Selecting an area in the bitmap



Pasting without an area selected
Step-by-step

You can paste the contents of the Windows Clipboard into a bitmap as a detached selection.

To paste a bitmap as a detached selection:
1. Clear any selections by clicking in the bitmap outside of the selection box.
2. From the Edit menu, choose Paste. Or press Shift+Ins.
3. To adjust the position of the pasted bitmap, drag the selection box as a detached selection.

See also
Detaching and moving a selected area
Pasting into a selected area
Pasting without Clipboard colors



 

Pasting into the selected area
Step-by-step

You can paste the contents of the Windows Clipboard into an area of the bitmap that you specify. BitEdit stretches 
or shrinks the pasted bitmap to fit it into the selected area.

To paste a bitmap into a selected area:
1. Select the bitmap area you want to replace with the pasted bitmap.
2. From the Edit menu, choose Paste. Or press Shift+Ins.
3. To adjust the position of the pasted bitmap, drag the selection box as a detached selection.

See also
Detaching and moving a selected area
Pasting without an area selected
Pasting without Clipboard colors



Pasting without Clipboard colors
Step-by-step

You can paste an image from the Windows Clipboard without pasting its color palette. BitEdit pastes the image as 
a detached selection and maps its colors to the current bitmap's palette.

To paste a bitmap into a selected area:
1. Select the bitmap area you want to replace with the pasted bitmap.
2. From the Edit menu, choose Paste Without Color.
3. To adjust the position of the pasted bitmap, drag the selection box as a detached selection.

See also
Detaching and moving a selected area
Pasting into a selected area
Pasting without an area selected



Pasting into a new BitEdit window
Step-by-step

You can copy the contents of the Windows Clipboard to a new BitEdit window, edit the image, and then insert the 
edited image into your bitmap.

To paste the Clipboard contents into a new BitEdit window:
1. From the File menu, choose Run BitEdit.
2. From the Edit menu of the new instance of BitEdit, choose Paste.

You can edit this image, save it, and copy it to the Clipboard before inserting it into another bitmap.



Using transparent color
Step-by-step

You can change the current background color to transparent so that when you paste a bitmap from the Clipboard, 
only the foreground image appears, and extraneous background details are transparent. To do this, color over the 
details in the image that you do not want with the background color, then check    the Use Transparency command 
and paste the image.

To copy an object without background detail:
1. Select the bitmap area with the background you want to make transparent.
2. From the Selection menu, choose Crop.
3. Set the background color to a color that highly contrasts with the bitmap area you're pasting.
4. Select the brush tool, and Shift+drag to brush the background color over all the details you want to become 

transparent.
5. From the Edit menu, choose Select All, then choose Copy.
6. From the File menu, choose Open to open the bitmap file that you want to paste the image into.
7. From the Options menu, choose Use Transparency.
8. Set the background color for this bitmap to the same color you selected in Step 3.
9. From the Edit menu, choose Paste.

If the pasted image's palette differs from the current bitmap's palette, when you paste, a dialog box appears 
asking whether you want to map colors from one to the other. Click OK to continue or Cancel to cancel the 
paste.

See also
Changing background and foreground colors
Detaching and moving a selected area
Drawing ellipses and circles
Drawing rectangles



Cropping a bitmap
Step-by-step

You can use the Crop command to cut away or crop sections of a bitmap outside of a selected area.

To crop a bitmap:
1. Select the area of the bitmap that you want to keep.
2. From the Selection menu, choose Crop.

See also
Resizing a bitmap



Flipping the selected area
Step-by-step

You can flip a selected bitmap area across its horizontal or vertical axis.

To flip the selected bitmap area:
1. Select the bitmap area that you want to flip.
2. From the Selection menu, choose Flip Horizontal or Flip Vertical.

See also
Rotating the selected area



Rotating the selected area
Step-by-step

You can rotate a selected bitmap area 360 degrees around an axis.

To rotate the selected bitmap area:
1. Select the bitmap area you want to rotate.
2. From the Selection menu, choose Rotate.
3. Enter the number of degrees you want to rotate the selection.

Enter a positive value to rotate the selection clockwise, or a negative value to rotate it counterclockwise. The 0°
position is the original orientation of the selection.

4. To set the current background color to a transparent color, check Use Transparency.
5. Click Rotate to see the effect of your settings.
6. Click Done to accept the rotation.

See also
Changing background and foreground colors
Flipping the selected area
Using transparent color



Resizing a bitmap
Step-by-step

You can resize a bitmap to change its height, width, and color depth. When you change the height or width, you 
can choose whether to crop to the new size, or proportionally resize the image.

To resize a bitmap:
1. From the Options menu, choose Resize Image.
2. Enter new values in the Width and Height boxes.
3. Do one of the following:

Check Scaling Resize to scale the bitmap to the new width and height of the bitmap.

Uncheck Scaling Resize to crop the bitmap to the new values if they are smaller than the 
original bitmap, or to have BitEdit fill in around the image with the background color if they are larger than the original 
bitmap.
4. Check Retain Proportions to maintain the original aspect ratio.
5. Under Colors, select the color depth you want:

1-bit per pixel for a 2-color bitmap.

4-bits per pixel for 16 colors.

8-bits per pixel for 256 colors.
6. Click OK.



Undoing changes
Step-by-step

You can reverse the effect of your most recent action in the current instance of BitEdit, if that action can be 
reversed. When an action cannot be reversed, the command is dimmed on the menu. You can also revert to the 
last version of a bitmap that was saved.

To undo a change:

Choose Undo from the Edit menu.
To revert to the last version of the bitmap that was saved:

Choose Revert from the File menu.



Changing background and foreground colors
Step-by-step

When you draw shapes with BitEdit's tools, BitEdit colors the shape using the current foreground and background 
colors. You can change the background and foreground colors to any color used by the bitmap.

To use the current color tool:
1. Point to the current color tool, then do one of the following:

To change the foreground color, hold down the left mouse button.

To change the background color, hold down the right mouse button.
2. Drag to move a flashing selection box to the color you want, then release the mouse.

To use the color dropper tool:
1. Click the color dropper tool.
2. Point to the color in the bitmap that you want, then do one of the following:

Click with the left mouse button to set the foreground color.

Click the right mouse button to set the background color.

To use the brush tool:
1. Click the brush tool.
2. Point to the color in the bitmap that you want, then do one of the following:

Press Ctrl+the left mouse button to set the foreground color.

Press Ctrl+the right mouse button to set the background color.



Using the brush tool
Step-by-step

You can paint the current foreground or background color on a bitmap with the brush tool.

To draw with the brush tool:
1. Click the brush tool.
2. Point to the place on the bitmap where you want to begin drawing.

To begin drawing using the foreground color, hold down the left mouse button, then drag the 
mouse.

To begin drawing using the background color, hold down the right mouse button, then drag the 
mouse. Or press Shift while dragging with the left mouse button.

To set foreground and background colors with the brush tool:
1. Click the brush tool.
2. Point to the color in the bitmap that you want, then do one of the following:

Press Ctrl+the left mouse button to set the foreground color.

Press Ctrl+the right mouse button to set the background color.

See also
Changing the shape of the brush
Controlling line width



Controlling line width
Step-by-step

    You can set the line width used when you draw with the brush, rectangle, rounded rectangle, ellipse, line, and 
color eraser tools.

To change the line width:
1. Point to the line size tool, then hold down the left mouse button.
2. Drag to select the line width you want.

See also
Drawing ellipses and circles
Drawing rectangles
Drawing straight lines
Using the brush tool



Changing the shape of the brush
Step-by-step

You can set the brush shape used when you draw with the brush tool.

To change the shape of the brush:
1. Point to the brush shape tool, then hold down the left mouse button.
2. Drag to select the brush shape you want.

See also
Controlling line width
Using the brush tool



Drawing rectangles
Step-by-step

You can draw a rectangle filled with either the current foreground or background color, or with a transparent fill.

 

To draw a rectangle:
1. Click the rectangle or rounded rectangle tool.
2. Point to the place on the bitmap where you want one corner of the rectangle to start.

To draw a rectangle with the current foreground color forming the edge of the rectangle and the 
background color filling the border, hold down the left mouse button, then drag.

To draw a rectangle with the background color forming the edge of the rectangle and the 
foreground color filling the border, hold down the right mouse button, then drag. Or Shift+drag the tool with the left 
mouse button.

3. When the rectangle is the size you want, release the mouse button.

 

To draw a rectangle with a transparent fill:
1. Click the rectangle or rounded rectangle tool.
2. From the Options menu, choose Use Transparency.
3. Point to the place on the bitmap where you want one corner of the rectangle to start.

To draw a rectangle with the current foreground color forming the edge of the rectangle, hold down 
the left mouse button, then drag.

To draw a rectangle with the background color forming the edge of the rectangle, hold 
down the right mouse button, then drag. Or Shift+drag the tool with the left mouse button.

4. When the rectangle is the size you want, release the mouse button.

See also
Changing background and foreground colors
Controlling line width
Drawing ellipses and circles
Drawing straight lines



Drawing ellipses and circles
Step-by-step

You can draw an ellipse filled with either the current foreground or background color, or with a transparent fill.

To draw an ellipse:
1. Click the ellipse tool.
2. Point to the place on the bitmap where you want one corner of the ellipse to start.

To draw an ellipse with the current foreground color forming the edge of the shape and the 
background color filling the border, hold down the left mouse button, then drag.

To draw an ellipse with the background color forming the edge of the shape and the 
foreground color filling the border, hold down the right mouse button, then drag. Or Shift+drag the tool with the left 
mouse button.

3. When the shape is the size you want, release the mouse button.

To draw an ellipse with a transparent fill:
1. Click the ellipse tool.
2. From the Options menu, choose Use Transparency.
3. Point to the place on the bitmap where you want one corner of the ellipse to start.

To draw an ellipse with the current foreground color forming the edge of the shape, hold down the 
left mouse button, then drag.

To draw an ellipse with the background color forming the edge of the shape, hold down 
the right mouse button, then drag. Or Shift+drag the tool with the left mouse button.

4. When the shape is the size you want, release the mouse button.

See also
Changing background and foreground colors
Controlling line width
Drawing rectangles
Drawing straight lines



Drawing straight lines
Step-by-step

You can draw a straight line using either the current foreground or background color.

To draw a straight line:
1. Click the line tool.
2. Point to the place on the bitmap where you want one end of the line segment to start.

To draw a line using the foreground color, hold down the left mouse button, then drag.

To draw a line using the background color, hold down the right mouse button, then drag. 
Or Shift+drag the tool with the left mouse button.

3. When the line is the length you want, release the mouse button.

See also
Changing background and foreground colors
Controlling line width
Drawing ellipses and circles
Drawing rectangles
Using the brush tool



Filling in a section of a bitmap
Step-by-step

You can replace a section of a bitmap that is one color with another color. The Flood Fill tool changes all adjoining 
pixels that are one color to the current foreground or background color.

To fill in a section of a bitmap:
1. Click the flood fill tool.
2. Point to the part of the bitmap you want to fill.

To fill the section with the foreground color, click the left mouse button.

To fill the section with the background color, click the right mouse button. Or Shift+click the left 
mouse button.

See also
Changing background and foreground colors
Using the color eraser



Using the color eraser
Step-by-step

You can change foreground-color pixels in a bitmap to the background color, or vice versa. You can use the color 
eraser tool with the current color tool to change part or all of any color in a bitmap to any available color.
The size of the color eraser tool changes depending on the current line width setting.

To change pixel colors:
1. Click to select the color eraser tool.
2. If necessary, change the size of the color eraser tool using the line width tool.
3. Point to the place in the bitmap where you want to begin erasing.

To change foreground-color pixels to the background color, hold down the left mouse button, then 
drag.

To change background-color pixels to the foreground color, hold down the right mouse button, then 
drag. Or Shift+drag with the left mouse button.

See also
Changing background and foreground colors
Controlling line width
Filling in a section of a bitmap



Using the zoom control tool
Step-by-step

You can magnify a portion of a bitmap two, four, or eight times its original size.

To magnify a bitmap area:
1. Point to the zoom control tool, then hold down the mouse.
2. Drag to select the magnification option you want.
3. Move the zoom selection box to the area you want, then click.
Tip:    Move the zoom selection box by pointing to the top of the box and dragging it.



Replacing a bitmap palette
Step-by-step

You can cut or copy the palette from another bitmap file, then paste it into BitEdit to replace the palette of the 
currently displayed bitmap. The colors in the bitmap change to display the colors of the new palette.

To replace a bitmap's palette with another palette:
1. From the File menu, choose Open.
2. Under File Name, select or type the name of the bitmap file that contains the palette you want to use, then click 

OK to open the bitmap.
3. Select all or any part of the bitmap.
4. From the Edit menu, choose Copy.
5. From the File menu, choose Open, then select the bitmap that contains the palette you want to replace.
6. From the Edit menu, choose Paste Palette.

See also
Reducing colors



Reducing colors
Step-by-step

You can reduce the number of colors in a bitmap's palette so that one image doesn't use up all the system's color 
resources.

To reduce the number of colors used in a bitmap:
1. From the Options menu, choose Color Reduction.
2. In the Reduce To box, enter the number of colors you want to retain.
3. Do one of the following:

Choose Optimal Palette to locate a palette of a specified size that best represents the image.

Choose Optimal Palette For Selection to locate the optimal palette for the colors in a 
selected area of the bitmap. This option is dimmed when no bitmap area is selected.

Choose Truncated Palette to keep the top palette entries and discard lower palette entries.
The truncated colors are then mapped to the closest remaining color entries.

Choose Palette From File to replace the current bitmap palette with a palette file that you 
specify.
4. Choose Dither to reduce the palette and dither the bitmap.
5. Choose Accept to reduce the palette but not dither the bitmap.



Reordering a color palette
Step-by-step

You can reorder the colors in a bitmap's palette to prioritize the colors most critical to displaying the bitmap.

To move the colors in a selection to the top of a color palette:
1. Select the bitmap area that contains the colors you want to reorder.
2. From the Edit menu, choose Selected Colors First.



Selecting palette colors from BitEdit
Step-by-step

When you are working in BitEdit and PalEdit together, you can select colors from a section of your bitmap in the 
BitEdit window, then highlight them in PalEdit so that you can edit them.

To select the colors in PalEdit that are used by a BitEdit selection:
1. Select the bitmap area that contains the colors you want to highlight in PalEdit.
2. Choose Select in PalEdit from the Edit menu.
Tip:    To work with the selected colors in PalEdit, click the PalEdit title bar.



Detaching and moving the tools window
Step-by-step

You can detach the tools window, so you can move it to a convenient location onscreen.

To detach and move the BitEdit tools window:
1. From the Edit menu, choose Preferences.
2. Choose Detach Tools Window.
3. Click OK.
4. Drag the tools window by its title bar to the location you want.



Selection tool
BitEdit tool

Selects an area of a bitmap.
You use the selection tool to select areas of the bitmap or the entire bitmap so that you can work with it. Dragging 
with the selection tool creates a flashing selection box that you can move and resize.

See also
Cropping a bitmap
Detaching and moving the selected area
Moving a copy of the selected area
Moving the selection box
Pasting into the selected area
Reducing colors
Resizing the selection box
Selecting an area in the bitmap
Selecting palette colors from BitEdit



Brush tool
BitEdit tool

Draws in the current color on a bitmap.
Use the brush tool to draw lines and arcs of different shapes, widths, and colors on any displayed bitmap. You can 
use the brush shape tool to adjust the brush shape to a circle or a square. Use the line size tool to adjust the width
of the lines.

See also
Changing background and foreground colors
Changing the shape of the brush
Controlling line width
Using the brush tool



Rectangle tool
BitEdit tool

Draws rectangles on a bitmap.
You use the rectangle tool to draw rectangles of different shapes, widths, and colors on a displayed bitmap. Use 
the line width tool to adjust border widths. Use the current color tool to change the border and fill colors. Use the 
Use Transparency command from the Options menu with the rectangle tool to draw rectangles with a transparent 
fill.

See also
Changing background and foreground colors
Controlling line width
Drawing rectangles



Rounded rectangle tool
BitEdit tool

Draws rounded-corner rectangles on a bitmap.
You use the rounded rectangle tool to draw rounded-corner rectangles of different shapes, widths, and colors on a 
displayed bitmap. Use the line width tool to adjust border widths. Use the current color tool to change the border 
and fill colors. Use the Use Transparency command from the Options menu with the rounded rectangle tool to 
draw rounded rectangles with a transparent fill.

See also
Changing background and foreground colors
Controlling line width
Drawing rectangles



Ellipse tool
BitEdit tool

Draws ellipses on a bitmap.
You use the ellipse tool to draw ellipses of different shapes, widths, and colors on a displayed bitmap. Use the line 
width tool to adjust border widths. Use the current color tool to change the border and fill colors. Use the Use 
Transparency command from the Options menu with the ellipse tool to draw ellipses with a transparent fill.

See also
Changing background and foreground colors
Controlling line width
Drawing ellipses and circles



Line tool
BitEdit tool

Draws line segments on the bitmap.
You use the line tool to draw line segments of different widths and colors on a displayed bitmap. Use the line width
tool to adjust line thickness. Use the current color tool to select line color.

See also
Changing background and foreground colors
Controlling line width
Drawing straight lines



 

Color dropper tool
BitEdit tool

Sets foreground and background colors from a bitmap.
You use the color dropper tool to choose the foreground and background colors directly from the bitmap. Use the 
left mouse button to set the foreground color and the right mouse button to set the background color.

See also
Changing background and foreground colors



 

Flood fill tool
BitEdit tool

Fills a bitmap area with a color you select.
You use the flood fill tool to fill a selected bitmap area with either the foreground or background color. The flood fill 
tool changes all adjoining pixels of one color.

See also
Filling in a section of a bitmap



Color eraser tool
BitEdit tool

Changes areas from foreground color to background color and vice versa.
You use the color eraser tool to change the foreground color in a bitmap to the background color, or vice versa. 
You can change any part of a bitmap to any available color.

See also
Using the color eraser



Current color tool
BitEdit tool

Sets foreground and background colors from a color palette.
You use the current color tool to choose the foreground and background colors from a bitmap's palette. Use the 
left mouse button to set the foreground color and the right mouse button to set the background color. Point to the 
tool and hold down the mouse button to see the color options.

See also
Changing background and foreground colors



Line size tool
BitEdit tool

Sets the line width for the brush and color eraser tools.
You use the line width tool to adjust the width of the lines produced by the brush and color eraser tools. Point to 
the tool and hold down the mouse button to see the size options.

See also
Controlling line width



 
Brush shape tool
BitEdit tool

Sets the shape used by the brush tool.
Use the brush shape tool to adjust the shape of the brush tool to a circle or square. Point to the tool and hold down
the mouse button to see the shape options.

See also
Changing the shape of the brush



Zoom control tool
BitEdit tool

Magnifies the bitmap image.
You use the zoom control tool to magnify portions of a bitmap two, four, or eight times so that you can more easily 
edit bitmap areas. Magnifying the bitmap displays each pixel in a larger size. The zoom control tool is particularly 
useful for highly detailed, pixel-by-pixel editing.

See also
Using the zoom control tool



File menu
Menu commands
Contains commands for managing bitmap files. Scroll to see descriptions of each command.

New
Creates a new, empty bitmap file with the dimensions and number of colors that you specify.
See also
Creating a new bitmap file

Open
Opens an existing bitmap file.
See also
Opening a bitmap file
Valid file formats to open

Close
Closes the current bitmap file without exiting BitEdit.

Save
Saves a bitmap under its current file name.
See also
Saving changes to a bitmap
Valid file formats to save

Save As
Saves a bitmap under a specified file name. A bitmap can be saved under its current file name or under a different 
one.
See also
Saving changes to the bitmap
Valid file formats to save

Revert
Replaces the current bitmap with the last version that was saved. BitEdit prompts you before discarding the 
current bitmap.
See also
Undoing changes

Run BitEdit
Starts a new instance of BitEdit.

Exit
Closes the current bitmap file and quits BitEdit.
See also
Quitting BitEdit



Edit menu
Menu commands
Contains commands for editing bitmap files. Scroll to see descriptions of each command.

Undo
Undoes the last complete operation.
See also
Undoing changes
Setting preferences

Cut
Removes the selection and copies the bitmap's palette, then places both on the Windows Clipboard, replacing the 
previous contents of the Clipboard. The removed section is filled with the current background color. If nothing is 
selected, the command is dimmed on the menu.
See also
Selecting an area in the bitmap

Copy
Copies the selection and the bitmap's palette, then places both on the Windows Clipboard, replacing the previous 
contents of the Clipboard. If nothing is selected, the command is dimmed on the menu.
See also
Selecting an area in the bitmap

Paste
Places the contents of the Windows Clipboard, including the color palette, into the current bitmap. Colors from the 
Clipboard palette are mapped to any empty cells at the bottom of the bitmap's palette. If the pasted palette 
contains more colors than cells are available, BitEdit maps as many colors as it can and discards the rest. Any 
unmapped colors used by the pasted bitmap are remapped to available colors.
See also
Pasting into a new BitEdit window
Pasting into the selected area
Pasting without an area selected
Pasting without Clipboard colors
Using transparent color

Paste Without Color
Places the contents of the Windows Clipboard, but not the color palette on the Clipboard, into the current bitmap. 
BitEdit maps the colors in the pasted bitmap to the closest matching colors in the current palette.

Paste Palette
Pastes the contents of the Windows Clipboard into the current bitmap's palette, replacing the previous palette. 
Colors in the bitmap are remapped to the new palette. The command is dimmed on the menu if the Clipboard 
contains anything other than a bitmap or palette file.
See also
Replacing a bitmap palette

Delete
Removes the current selection without placing it on the Windows Clipboard. If nothing is selected, the command is
dimmed on the menu.
See also
Selecting an area in the bitmap

Select All
Selects the entire bitmap and its palette.



Preferences
Allows you to customize your working environment by setting different options for BitEdit. Changes in this dialog 
box take effect immediately.
See also
Setting preferences



Selection menu
Menu commands
Contains commands for working with a selected bitmap area. Scroll to see descriptions of each command.

Crop
Removes areas of a bitmap outside of the selected bitmap area.
See also
Cropping the bitmap
Selecting an area in the bitmap

Flip Horizontal
Flips a selected bitmap area across its horizontal axis, producing a mirror image of the original selection.
See also
Flipping the selected area
Rotating the selected area
Selecting an area in the bitmap

Flip Vertical
Flips a selected bitmap area across its vertical axis, producing an upside down version of the selection.
See also
Flipping the selected area
Rotating the selection
Selecting an area in the bitmap

Rotate
Rotates a selected bitmap area up to 360 degrees around an axis.
Tip:    Rotate the selection 180 degrees to produce the same effect as using the Flip Vertical and Flip Horizontal 
commands together.
See also
Flipping the selected area
Selecting an area in the bitmap

Selected Colors First
Moves the colors in a selected area to the top of the bitmap's color palette to prioritize colors that are most 
important for image display.
See also
Reordering a color palette
Selecting an area in the bitmap

Select In PalEdit
Causes the colors in a selected area of the bitmap displayed in BitEdit to be selected in the palette displayed in 
PalEdit. The command is dimmed on the menu if PalEdit is not open.
See also
Selecting palette colors from BitEdit
Selecting an area in the bitmap



Options menu
Menu commands
Contains commands for modifying the size and image quality of a bitmap file. Scroll to see descriptions of each command.

Show Palette
Runs PalEdit to show the color palette associated with the displayed bitmap.

Color Reduction
Reduces the number of colors used in a bitmap by removing or changing colors in the bitmap's palette. Choose 
from four color reduction methods (optimal palette, optimal palette for the selected area, truncated palette, and 
pasting another file's palette) and a Dither button that dithers colors in the bitmap in areas of gradual transition.
See also
Reducing colors

Resize Image
Resizes the height, width, and image depth for the displayed bitmap.
See also
Resizing a bitmap

Use Transparency
Changes the current background color to transparent. If you check Use Transparency then paste from the 
Clipboard, the bitmap is pasted with a transparent background so that the image underneath shows. If you check 
Use Transparency then draw with the rectangle, rounded rectangle, or ellipse tools, the interior of the object is 
transparent.
See also
Changing background and foreground colors
Drawing ellipses and circles
Drawing rectangles
Using transparent color



Valid file formats to open
Menu commands

BitEdit can open a bitmap file stored in any of these file formats:
Format Extension
Microsoft Windows DIB .DIB, .BMP
Microsoft Windows Metafile .WMF
Microsoft RLE DIB .DIB
Microsoft RIFF DIB .RDI
Microsoft RIFF RLE DIB .RDI
PC Paintbrush .PCX
CompuServe GIF .GIF
Apple Macintosh PICT .PIC
Truevision TGA .TGA
AutoCAD Import .PLT
Computer Graphics Metafile .CGM
HP Graphic Language .HGL
Lotus 1-2-3 Graphics .PIC
Encapsulated Postscript .EPS
Micrografx Designer or Draw .DRW
Tag Image File Format .TIF

See also
Valid file formats to save



Valid file formats to save
Menu commands

BitEdit can save a bitmap file in any of these file formats:
Format Extension
Microsoft Windows DIB .DIB
Microsoft RLE DIB .DIB
Microsoft RIFF DIB .RDI
Microsoft RIFF RLE DIB .RDI
PC Paintbrush .PCX
Apple Macintosh PICT .PIC
Truevision TGA .TGA

See also
Valid file formats to open



Technical support contact information
Step by step

Telephone support
Use the following Asymetrix technical support telephone numbers as needed for your location.

Australia/Asia Pacific

    Infotainment Asia Pacific Pty Ltd.
(61+3) 5255-471 (direct)
(61+3) 5255-482 (fax)

9 a.m. to 6 p.m. Eastern Standard Time

    XLTECH Pty Ltd.
(61+2) 9752-111 (direct)
(61+2) 9752-167 (fax)

9 a.m. to 6 p.m. Eastern Standard Time

Europe (except France, Germany, and United Kingdom); Middle East; Africa; 
Russia

+44 923-208-433 9:00 to 17:00 GMT

France
05-90-83-19 (freephone) 9:00 to 17:00 GMT

Germany
01-30-81-27-07 (freephone) 9:00 to 17:00 GMT

United Kingdom
0800-716-957 (freephone) 9:00 to 17:00 GMT

U.S.A. and rest of world
206-637-1600 (direct)
206-454-0672 (fax)

6 a.m. to 6 p.m. Pacific time Monday through Thursday; 6
a.m. to 3 p.m. Friday

Online services
Asymetrix provides complimentary support via Asymetrix Bulletin Board System (BBS), CompuServe, America 
Online, and Internet to registered users. Technical support responds to online queries within 48 hours (Monday 
through Friday).

Asymetrix BBS
Do one of the following:

If you have a 1200 to 14,400 baud modem (v.32bis), call (206)-451-1173.

If you have a 9600 to 14,400 baud modem (v.32bis), call (206)-451-8290.
America Online
Do one of the following:

From the Go To menu, select Keyword, then type Asymetrix.

Go to the Computing and Software area, select Industry Connection, then select Asymetrix.



CompuServe
To connect to

Windows Third Party Developer A forum, Section 1, type GO ASYMETRIX or GO WINAPA at the 
prompt.

Multimedia Vendors forum, Section 15, type GO MULTIVEN at the prompt.

IBM Ultimedia Tools A forum, Section 5, type GO ULTIATOOLS at the prompt.
Internet
Enter one of the following addresses:

techsup@asymetrix.com

support@asymetrix.com




